User Tools

Site Tools


basic_game_image_editing_with_gimp

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
basic_game_image_editing_with_gimp [2014/03/29 02:58]
mithat
basic_game_image_editing_with_gimp [2014/03/29 04:57] (current)
mithat
Line 1: Line 1:
-====== Basic Games Image Editing with GIMP ======+====== Basic Game Image Editing with GIMP ======
  
 This is a guide to using [[http://www.gimp.org|GIMP]] for doing some of the more common kinds of things you need to do when editing images for use in games. This is a guide to using [[http://www.gimp.org|GIMP]] for doing some of the more common kinds of things you need to do when editing images for use in games.
Line 27: Line 27:
   - Go to [[http://www.gimp.org/downloads/|the GIMP download page]].   - Go to [[http://www.gimp.org/downloads/|the GIMP download page]].
   - Follow the instruction under "GIMP for Unix-like systems" to install GIMP for your distribution.   - Follow the instruction under "GIMP for Unix-like systems" to install GIMP for your distribution.
 +
 +<WRAP center round tip 60%>
 +Watch the videos below at high resolution and full screen.
 +
 +To increase resolution, start playing the video, then click the gear icon in the player toolbar, then select 720pHD.
 +
 +To view full screen, click the "Full screen" icon in the player toolbar.)
 +</WRAP>
  
 ===== Converting images to PNG ===== ===== Converting images to PNG =====
Line 33: Line 41:
     - Be sure //Select File Type// is set to //(By Extension)//.     - Be sure //Select File Type// is set to //(By Extension)//.
     - Enter ''imageName.png'' (Make sure the extension is ''.png'')     - Enter ''imageName.png'' (Make sure the extension is ''.png'')
-    - Click "Export"+    - Click "Export"You may have to click it twice. (I don't know if this is a bug or not.) 
-  - To save changes you have made to a PNG file, go to //File > Export to imageName.png//+    In the resulting dialog, just go with the defaults and cick "Export"
 + 
 +{{youtube>BRpLJcyNFp4?large}} 
 + 
 +Note: To save any changes you have made to a PNG file, go to //File > Export to imageName.png// If you do a //File > Save// or //File > Save As...//, GIMP will save the file in its own .xcf format. 
  
 ===== Cropping images ===== ===== Cropping images =====
Line 44: Line 56:
     - You can change the selected area by clicking and dragging on any of the rectangles in the four corners.     - You can change the selected area by clicking and dragging on any of the rectangles in the four corners.
   - Crop away the unwanted bits by going to ''Image > Crop to Selection''   - Crop away the unwanted bits by going to ''Image > Crop to Selection''
 +
 +{{youtube>ahn86V_2-Ak?large}}
  
 ==== Autocrop ==== ==== Autocrop ====
Line 49: Line 63:
   - //Select > All//   - //Select > All//
   - //Image > Autocrop image//   - //Image > Autocrop image//
 +
 +{{youtube>Fhq55GBJzy0?large}}
  
 ===== Making backgrounds transparent ===== ===== Making backgrounds transparent =====
 +The following assumes the image you want to modify is well-suited to having its background made transparent. An image that's well suited to this is one where:
 +
 +  * The backgrond is all one color.
 +  * The image has a clear border.
 +
 +You can still make backgrounds transparent with images that don't meet both these requirements, but the process is more involved.
 +
 +To make the background of a "well suited" image transparent:
 +  - Add a transparent layer to the image with //Layer > Transparency > Add Alpha Channel//.
 +  - Select the Fuzzy Select Tool (//Tools > Selection Tools > Fuzzy Select// or in the Toolbox).
 +  - Click on the background.
 +    - Confirm that the background has been correctly detected and selected.
 +    - You may need to adjust the tool's Threshold parameter to get the best results.
 +    - You can "unselect" everything from //Select > None//.
 +  - Clear the selected region by going to //Edit > Clear// or by hitting the Delete key.
 +
 +{{youtube>OcIUi6Xg51I?large}}
 +
 +===== Resizing images =====
 +To shrink an image down,
 +  - Go to //Image > Scale Image...// (NOT //Canvas Size...// or //Print Size...//).
 +  - In the dialog's Image Size area, select **pixels** from the top right-side dropdown menu.
 +  - If you want the height and width to scale proportionately, make sure the link image is set to "linked".
 +  - Set the width and/or height.
 +  - Click the "Scale" button.
 +
 +{{youtube>eepNKM610JM?large}}
  
 +Feel free to experiment with the different Interpolation settings. Some algorithms work better for some images than others. "Cubic" seems to be a good default. You can use the above method to make an image larger as well, but shinking images works muuuuch better than making them larger.
basic_game_image_editing_with_gimp.1396061930.txt.gz · Last modified: 2014/03/29 02:58 (external edit)